предложения

Опубликовано Гость в 19 Май, 2009 - 15:21

Пока знаком толька ”около”-недели!
Оч-Прикольная Шняга!
предложения по программе:
Возможность ”выбора” нескольких ИБ из ”списка” для Загрузки(/)Выгрузки (далее- ”действий”);
(напр.: типа- колонки с ”галочками” или списка с ”отметками” в 1эСине)
Сделать более-”Отличающимися” кнопки (напр.-картинки на кнопках) для ”действий” над ”1 ИБ” и Над ”Всеми ИБ”;
Добавить ”возможность” удаления файла не только из ”Брать Из:”, а также и ”Ложить в каталог:”, если он ”удачно обработан”;
(или других способов ”избежать” напр. вот ”это”

И возможно- Более-”фантастичные” пожелания :) :
Обходиться 1 Общим ”запуском 1с” на все ”выбраные” действия;
”отсекать” ”появление” файла в ”определённой” директории ( возможность) автоЗапускать ”загрузку” Свеже-случившегося файла,
с последующей выгрузкой ”Всех ИБ”;

”это” ( в предыдущем

”это” ( в предыдущем сообщении- потерялось)
Ошибка! Файл ”D:archАфтаАбменК05_Out.zip” устарел!
(образец ”проблемки”, в результате того, что файл будучи ”загружен” остался лежать в каталоге (”Ложить в каталог:”) и никто специально не полез его ”прибить”.

т.е- сделать

т.е- сделать максимально-упращённой стандартную процедуру Загрузить всё, что Можно и ”НУЖНО”( ещё не грузили) с Последующей выгрузкой ВСЕМ ( ИБ) ”свежестей”!

Спасибо за пожелания, в

Спасибо за пожелания, в следующих версиях программы ”УРБД Мастер” постраюсь реализовать эти задумки.

Можно ли добавить оповещение

Можно ли добавить оповещение пользователя о том что нужно выйти из базы если в файле обмена есть мд файл?

Эта функция уже давно

Эта функция уже давно реализована. Вот фрагмента из помощи к программе:

Если поставить флажок на Запускать монопольно если в архиве есть MD-файл то при наличии в файле обмене MD-файл программа попросит всех пользователей работающих в данный момент выйти из программы 1С: Предприятие и запустив 1С: Предприятие монопольно обновит данные.

При установленном Запускать монопольно если архив больше (КБайт) конфигуратор будет запускаться в монопольном режиме, если размер файла обмена больше заданного.

Внимание! Для работы этой функции необходимо в глабальный модуль конфигурации внести следующие изменения:

Процедура УРБДМастерТестНаОбновление()
Если ФС.СуществуетФайл(КаталогИБ() +”URBDMasterStop”) = 1 Тогда
Предупреждение(”Через 45 секунд программа будет закрыта.” +РазделительСтрок+ ”Сохраните изменения!!!”,30);
ОбработкаОжидания(”УРБДМастерЗакрыть”,45);
КонецЕсли;
КонецПроцедуры

Процедура УРБДМастерЗакрыть()
ЗавершитьРаботуСистемы();
КонецПроцедуры

Процедура ПриНачалеРаботыСистемы()
…………………………………………….
…………………………………………….
…………………………………………….
//Проверяем было ли обновление и убран ли файл
Если ФС.СуществуетФайл(КаталогИБ() +”URBDMasterStop”) = 1 Тогда
Предупреждение(”Обновление еще не законченно ” ,5);
СтатусВозврата(0);
Возврат;
КонецЕсли;

ОбработкаОжидания(”УРБДМастерТестНаОбновление”,60);
…………………………………………….
…………………………………………….
…………………………………………….
КонецПроцедуры

Очень хотелось бы удаленное

Очень хотелось бы удаленное администрирование УРБД Мастер.

Такая идея уже возникала. Вот

Такая идея уже возникала. Вот только я пока даже не представляю как это сделать грамотно и более понятно для пользователя.

Хотелось бы видеть передачу

Хотелось бы видеть передачу параметров в запускаемое приложение по событиям. А то неудобно для каждой базы писать батник, когда можно обойтись одним и передавать в него параметры. Например имя выполняемого файла писать в ””, а все что после передавать в качестве параметров.

Реализовал передачу

Реализовал передачу параметров, качать версию 1.6.2.
Пример использования:

”notepad.exe” c:\mytext.txt

или можно и так:

”notepad.exe” ”c:\long path to file\mytext.txt”

Но если писать так, notepad.exe c:\mytext.txt, то будет подразумеваться, что это одна длинная команда без параметров.

При сохранении Настройки

При сохранении Настройки обмена, если количество записей больше чем помещается на экран, теряется фокус текущей настройки. Список выводится с первой строки.

Исправил, качать версию

Исправил, качать версию 1.6.2.

Можно что-либо придумать для

Можно что-либо придумать для случаев, когда файл для загрузки уже на месте, и брать его ни откуда не надо (почтовик увидел что письмо от робота, выложил присоединенный файл в нужный каталог и стартанул урбд-мастера) ?

Можно настроить обмен с

Можно настроить обмен с транспортом ”Локально”. И указать путь куда ”почтовик” будет выкладывать файл.

Добрый день! Для полноты

Добрый день!
Для полноты счастья не хватает функционала автообновления МД центральных баз. Т.е. указать каталог где лежит новый МД, и по расписанию проверять наличие этого самого МД, если он там есть, пытаться обновить текущую базу, при успехе выгрузить пакет. Актуально когда в автообмене 70 баз.
Спасибо.

Это задача не такая легкая,

Это задача не такая легкая, как кажется. 1С не позволяет объединять/заменять конфигурацию в пакетном режиме или с помощью автоматизации (ActiveX).
На данный момент есть некоторые решения этой задачи (см. на 1c.proclub.ru).
Эта задача, возможно, будет решена и нами, но будет представлять отдельный программный продукт.

При копировании новой ИБ на

При копировании новой ИБ на основе выбранной, если значение ”Посл. загрузка” было пустым, то у нового становится 30.12.1899, а значение ”Посл. выгрузка” не обнуляется, оставляя значение источника.
Логичным, на мой взгляд, будет оставлять их пустыми.

Вы правы, исправим.

Вы правы, исправим.

Автоматический переход от

Автоматический переход от одной задаче к другой.
В настройку обмена нужно добавить еще одну закладку ”Выполнение” после закладки ”Выгрузка”.
На ней зделать четыре два реквизита:
В случае успешного завершения выполнить задачу [реквизит выбора задачи]
[v] галка - ждать завершения
В случае не успешного завершения выполнить задачу [реквизит выбора задачи]
[v] галка - ждать завершения
Тогда упростится настройка автообмена между базами для которых важна последовательность.

Первое Есть ошибка Настройка

Первое Есть ошибка
Настройка обмена - Расписание - Границі времени - Время с
Если в это поле ввести 0:00:00 выскакивает окно с сообщением ”You must be in ShowCheckbox mode to set to this date”. После нажатия на ОК в реквизите таки устанавливается время 0:00:00, но после закрытия формы ”Границы времени” и повторного открытия введенное значение не сохраняется.
Второе
Я в Хелпе не нашел описания по работе с этой формой ”Границы времени”. Суть ее в общем ясна, но вот отдельные параметры как ”По точному рассписанию” вызывают вопрос, а ответа нет.

Я может быть не точно или не

Я может быть не точно или не понятно выразился но помоему задача перехода от одной задаче к другой легко встраиваентся и в вашу программу. Вот например есть на клубе проф. такая программа pnsheduler в ней это работает. И вашей тоже есть почти готовый блок. ”Групповые действия” - эдинственного чего им не хватает так это в ”Условия” добавить флаг ”Ожидать завершения” и ВСЕ!
Т.е. только после выполнения задач в группе ”Условия” выполняются задачи в группе ”действия”.
Ну конечно было бы неплохо добавить в ”Условия” возможность установить признак что то типа ”Переходить к действию только после успешного завершения” или наоборот … после неуспешного.

Планируется реализация обмена

Планируется реализация обмена по MAPI?
Если да, то в какие сроки?

Нет. А с чем связана

Нет. А с чем связана необходимость использовать MAPI?

Щас весь обмен более чем с 16

Щас весь обмен более чем с 16 базами реализован в The Bat! через MAPI, думал перенастроить всё с использованием ваше разработки, так как она более удобна и более функциональна.

MAPI (англ. Messaging

MAPI (англ. Messaging Application Programming Interface) - интерфейс программы, работающей с электронной почтой в Microsoft Windows. MAPI предоставляет богатые возможности по управлению почтовым ящиком, позволяет получать, читать, создавать, отправлять почтовые сообщения, присоединять к ним файлы (или получать доступ к присоединенным файлам) и т. д.

Программа УРБД Мастер и сейчас умеет присоединять получать, читать, создавать, отправлять почтовые сообщения, присоединять к ним файлы (или получать доступ к присоединенным файлам).

Наша компания использует 1С:

Наша компания использует 1С: Предприятие 8.1, будет ли переход на эту платформу? Если да, то когда ждать?

Очень хочется чтобы УРБД

Очень хочется чтобы УРБД Мастер запускал процесс загрузки/выгрузки по наличию файла-флага

>Очень хочется чтобы УРБД

>Очень хочется чтобы УРБД Мастер запускал
>процесс загрузки/выгрузки по наличию файла-флага
Не совсем понятно, что такое файл-флаг и какие действия он должен выполнять при наличии флага…

Хочется чтобы совмещенная

Хочется чтобы совмещенная загрузка/выгрузка была действительно совмещенной, тоесть конфигуратор запускался один раз, а не два как у меня сейчас(может что-то я не донастроил?). Обмен идет часто и система сильно напрягается и это значительно снизило бы нагрузку.

В принципе он (конфигуратор)

В принципе он (конфигуратор) и должен запускаться один раз.
Но должны стоять такие галки в настройке расписания ”Загр.->Выгр.” и ”Совмещенная Загр.->Выгр.”
Совмещенный режим поддерживается только в автоматическом расписании, вручную запустить его нельзя.

удаленный мониторинг в виде

удаленный мониторинг в виде центральной консоли, в которой есть список со статусами всех установленных служб (с возможностью перезапуска службы), получение списка прописанных там заданий, их статус (последнее время).
Если развить - можно дополнить управлением. Остановить, запустить выбранное задание.